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1. LEER

WS 78 5 P R AR (ARG, 25, K 7Eh p) R BB I A & G5 XU AR A 43
Lo 25 5 50 1 78 i P VRVE MR SR AR B 55 P, A 5 P A H R A e 2 BT T Y T L
PR THAR (A e DX T AR Pl o 7 AR 2 B DX A 2 BN — o MW7 G P T4
Mol AR KRR AES T

AR 7 55 55 (1 0 T 3 St T 300 AR e Sy B P b v o LT B PR T FR R R,
A EH T XIRE . HATC& R R T 1R 201 FH 1 Bl & he e 78 05 B 1 3%, O SER
TR R S AR BOE A B B 55 R, R #4850 NDVI.

A DL 2 5278 AL T Landsat 5 TM S5 N BEIR, &) (814 2009 4F 9 H 47,
SR FH S50t PG o0 A R B VR PR B 7 6 P R B AG BEOERR . W  TM SRR AR IE . BIHR
B 5. NDVI M5S0, Bandmath {5, 1E ENVIA.8 A TE BN A I 72

2. RERENH

1870 43 ALY o — Tl 7 B S FH P 8 B A SRS AR, e AR —ME TC I B3R HH G R 7 25
o3 10 32% 55 JORE W 78 a8 o0 SR A R, T T SR A R W B e (S A X 2 N R 2R
PEIIALE B, 5 BRI BOAEE A2 4% H AR ARG T B I B 28, dn e R 478 26 B2 v] U
SE B A

NI ERA R AR O A A SR B SR (AR AR

VFC = (NDVI - NDVIsoil)/ ( NDVIveg - NDVisoil) (1)
FHorh, NDVIsoil 9584 /2 #f B oHE B 78 55 X 35 NDVI B, NDViveg NIAXZR 5E 4 W 4k BT 7
#MME e NDVIE, BP4EREH A G NOVIE . PRAME TR A XA

NDVIsoil= (VFCmax*NDVImin- VFCmin*NDVImax) /( VFCmax- VFCmin)  (2)

NDVIveg= ((1-VFCmin)*NDVImax- (1-VFCmax)*NDVImin) /( VFCmax- VFCmin)  (3)

I FH X AN B - SRR 0 7 55 P 1R DG B2 115 NDVIsoil A1 NDViveg. 1% LA PRl 1% :

1) 24X AT UL B VFCmax=100%, VFCmin=0%.

AR (1) AR N:

VFC = (NDVI - NDVImin)/ ( NDVIimax - NDVImin)  (4)
NDVImax FI NDVImin Z3 5l 4 X 38 A 5 KR B /N ) NDVIE o B AN 7] 36k S 47 7 8 75, NDVImax
A NDVImin — M — & BAS FEIE Bl N B s K AR S /ML, BLAS R (R U 32 AR 4 5 S b
TH LR E -

2) B A ABELL AL VFCmax=100%, VFCmin=0%

A SR SO, BCSIECHE R A 5 R 1 S K AR RN e/ MELAE A VFCmax Al
VFCmin, 3 /> S 504 5 92 8% NDVIE A2 NDVImax 1 NDVImin.

LA SCEAR LR, B2 BAE VA E A NDVImax #1 NDVImin. VFCmax FH
VFCmin HRABZ Il 5 .

FIH Landsat 5 TM FI45 70— 7 1 R R 43t 78 o 2o B B A A B AR A R
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i KARE i
i v i
‘ Pl A 0 [ TR R AR ;
/' NDVI 42 \
-k ! |
. BRI e K |
I , ;
L —Y
: 5 SR :
| v §
\ HH SRS 15 ;
e
L 4T

K1 kR
BIETACTE: {6 )52 Landsat TM [ LAT 225 %dE, AU AR IEARRE . dbig
T 75 L S TM B 78 5, ASTAE A 23 IR AN S AR AT 8 B AR SRS IE AL 3,
ZJa R SR AT R R, BRI R AL T AT BUd S B A B L AT A
e SRR, AT U BRI BT e AR I R SR (R—REE), 2
JE T RARIE.
W 78 T A 5. 7EBoC kAL, NDVIveg fRFHE A AE B 7 di 5 o i
KA, BT HEZSRARRN, NDVIveg {H th 25 i [A) A1 2= fa) iy 48 . Kk,
TR P G R, BEAE R — 518, 4T NDVIsoil Fl NDViveg 1A AEHR[# &
fHo —RFR LR LR P, LSRN s, AR S By b ()
PR DL R AE . B T4 B AR PR, AR %S 2 FH L 78 55 B 7 0l SR A
5] - b7 55 258 N A NDVImax AT NDVImin {E9 NDVI veg H1 NDVisoil, X FExk
A AR 3 A NDVI veg FI1 NDVIsoil 155 EE A
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3. AL ETRE

3. 13 IREL

AR AT F A EE FakHhhl: http://datamirror.csdb.cn. 3 FIEE /2 2009 4 9 A 22
H ) 123-032/123-033.

TENEEARN 5, 75 FEERMRPER “BEIEME L7, 5252 A R MG
B, AT EHRRARIE.

[ em [ enze wm] wam | w6
20090922 0% A / .

T#2dR
HiE=RSIR
WHARWES
WENHER

20090922 0% a

Biodll 20 - | IEEEEE | B

FH&ATiE: 2000-09-22 02:43:08 TEAYE: 2009-09-22 02:43:3¢
Fig=E: 0

Et=8:
HL=8:
KT =8
BT =8:
FPAA/A: 14957974817

APASER: 45.77488343

R 40.32845 thui 43 116.70258

2: SREUGZAG AL I TA]
123-032 FF4fHS[A]: 2009-09-22 02:43:08 , H.LEAAE: 40.32845, 116.70258
123-033 JF4fiff[A]: 2009-09-22 02:43:32 , FLZELEE: 38.90284, 116.25526
e A SRR P A *MUTTXT S0/ i) SCENE_CENTER_SCAN_TIME 3 [ $24Hk s A% it 1] .

3. 28 S AR

HEH ENVI HR TM EFRThAE, DL 123-032 58U N EI A Bt fE, 123-033 #/E3E
A—F.

F—B. RS ER

(D TE ENVI g8, 1%+ File-> Open External File-> Landsat-> GeoTIFF with
Metadata, 7E 3 iEHE % HE 15123032_03220090922_ MTL.txt A4, ENVI
H AP EAR IR B AR, FFRBEE K =N b, af k-
AN/

() 1E ENVI F3gHurp, % Basic Tools->Preprocessing ->Calibration Utilities->
Landsat Calibration, E#A] WLI6-204MH (6 NEED, FT7F Landsat sEdr L .

= e B e R
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(3)  Landsat /&5 LH 2 Mo SO B BRBUHC I 805 5., B8 g B .
ENNS LS, 1% Calibration Type: Radiance.

(4)  EERH BRSO 4 15123032_03220090922_rad.img, By OK $h47 & kb
i,

0 ENVI Landsat Calibration =)

Landsat Satellite Sensor Landsat 5 TH

Data Acquisition Month : |September w

Data Acquisition Day : 22 9

Data Acquisition Year : 2009 Q
Sun Elevation (deg) : 45.78

Calibration Type @ Radiance (") Reflectance

[ Edit Calibration Parameters

Output Result to @ File () Memory

Enter Output Filename [TIcompress
BEE\2ASHIE \L5123032_03220090922_rad. ing

l{ 0K ][ Queue][Cancel]|

B 3: T™M 3l e b
15 2R T2 A BALA W/ (mP*sr*um),  FLAASH ZLR (4RSS R B
W) / Cem®™nm*sr), Fi# % 10 (555 EUESCHERIMEZAIT R BSQ, K & brss Fidt T
PR RN BSQ->BIL [ FEHL LB

B R

(D 1E T3 s, 3% $% Basic Tool-> Convert Data (BSQ, BIL, BIP), #E Convert File Input
File XfiEHEHHIERE b — D B B4 R . #.id5 ok $TFF Convert File Parameters [f]
R
(2) i%F¢ Output Interleave: BIP, Convert In Place: Yes (ANAERGHT A ST,
(3) i OK PATIbEE,
XFERATTIRIG T & FLAASH ZE R SR 5T = AE .

r = I
@ Convert File Parameters E@x

Input Interleave: BSQ

Output Interleave: ( BIL @ BIP

Convert In Place 7 Yes ‘fl

[ 0K ][ Buene ][Cancel]

K] 4: Convert File Parameters T HR
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3.3FLAASH K5 R IE

TEEFEH A, %FE Spectral->FLAASH, $1F FLAASH ThREKIAH S HEEN
(L A S EEEBHE
. i Input Radiance Image %l , & b — 20 HE & W W AR 9 R (E 24
15123032_03220090922_rad.img. fE Radiance Scale Factors XJiGHEH1IEHE Use single scale
factor for all bands (Single scale factor: 10.000000).
H.f Output Reflectance File #2126 B SO 44 AR A2
(2 RERESEBREBER
® lat: 40.32845, Lon: 116.70258 (M ICEE SCAEHFRED
® Sensor Type: Landsat TM5
® Ground Elevation (km): 0.043 (M AHRL[X Ik DEM 3RAF-FH4ME)
® Flight Date: 2009-09-22 Flight Time: 02:43:08 (M IR C/FHHFRED
(3) KA (Atmospheric Model): Sub-Arctic Summer
(4) SRS (Aerosol Model): Urban
(5) S5 (Aerosol Retrieval): 2-Band (K-T)
(6)  WIUARENLE (Initial Visibility): 40,
7 ZI61E B E (Multispectral Settings)
® Defaults [fi#E: Over-Land Retrieval Standard (660: 2100).
(8)  EZRi%E (Advanced Settings): tile & & N 100M, HAFIEIRINEE .
(9) i Apply %41, 4T FLAASH.
G s e o o et e R ==

M\ 75,‘.;7.7“'71{“‘! FADIEWFID weo \2003] 3 AR R B MR \2 A5 45 F \ 15123032 032200906022 red. ing

Output Tefiactance File | 7 \DIENVIDane 2000310 {1 38 0 0 \SHEE S 809\ 15123032 _03220000022_refl ing

Outgat Directory for FLMSH Files | D \Teng\

Bootasae for FLAMSH Files

Soane Cester Location | I <) MG

Seazor Type Landsat YMi; Fiight Date
ST -

Sep v |22 w| % $

TAE 90, 3640000 Sessor Altitude Om) 705.000
Flight Tine GAT 00 AN 55)
Lon, 116 70258722 Ground Elevatise Om) 0043 ? 8 Ge 8 &
Pizal Size &) 3 00

Aerosol Model Teban -/

Atmespheric Badel ‘jsi-g'—_kzh_t;sﬁgi" b
Re l_'l Asroxol Batrieval Z-Bund O-T)
ater Columm Multipiior 1.00 & Initial Vizibility Oe) 40.00
Aeply | [ Cancel || Help nltispectral Settings Ilfﬂ&;{ozf‘:;ﬁ{{éf Swvs | [ Festors.

K 5: %I\ FLAASH 2%
123-33 H R H B KSR IE T .
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3.4 Bk 5HEY

(1) 7F ENVI FE3gsrh, %4 Map—>Mosaicking—>Georeferenced, 7 Map Basic
Mosaic [t .

(2) {F Mosaic MitRH, #%FE Import—> Import Files, i%#% 123-32 fil 123-33 KK
RIEGRFAN

(3) mFEAHIR PRGN C, Bai AL SE Edit Entry.

(4) £ Edit Entry ik, %8 Data Value to Ignore: 0, ZW& 01{H.

(5) fE Mosaic MM, % File—>Apply, 7F Mosaic Parameters [t T+, & &%
G KN BERFET GLTERD « SUHERR K OSUHE4

[ Mosaic 9631 x 12531 (UTM, Zane SON... il =3 ki |

hio lm&m Options  Help

K 6. EMGaEER

{5 A6 54T BOD BT B

(1) &P FSEH->File->Open Vector File, 1 3 87 EUZ T TE X 35 1) Shapefile k& 3L
A OJEER AT X R BN\ T X shp), BEESEALE, EHFEF A Memory.

@) 7E Available Vector List [I#i H, %% File->Export Layer to ROI, {E 5 H BT 1EAE
GBI EIR, Hd OK.

(3)  f£ Export EVF layer to ROl IEFXIIHHES, EFMITEREEZER
ROI(Convert all record of an EVF layer to one ROI), H.d7 OK.

D) %43 3 3¢ Bi->Basic Tools->Subset data via ROls, E#3 5 K14,

(5) 1 Spatial Subset via ROl parameters h, WELLTFSH:

® 7 ROI %% (Select Input ROIs), 4L ROI.

® 1t “Mask pixels outside of ROI?” T, &+ yes.

® i EVi/H (Mask Background Value): 0.
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(6) R LU, Bl oK BT R .
(9 #1 scroll (0.05417) )

B 7 BT A R

3.5NDVI {+5&

B EHH ENVI i) NDVT 15 TR

(1) FEFFEHA, #%EFF Transforms ->NDVI. 7E NDVI Calculation Input File iAR H, #E#
™ B, sids “oK”.

(2) 7E NDVI Calculation Parameters X 1FHEHT, Hidi “Input File Type” TNH M., E#
Landsat TM. 115 NDVI FIU B8 H 8 R AF] “Red” 1 “Near IR” A
HEH

(3) & “Output Data Type” THisgHiEBHHTF A (Floating Point).

(4) s H AR SO 4, s “OK.

Phk: www.esrichina.com.cn  $RSZEEMUL: support.esrichina.com.cn  Hiif: 010-57632288 FiAR T Hr#k
£k: 400-819-2881-7



& esri china e

& 8: NDVI %45 R

HT RARIEFEREGRA I Gou Il FEERAEPRHX, X
BB XA EAA R H NDVT 7R [-1, 112 4h, N T EFRmE a8, AT E
WX G ITH NDVT (EAR e sl (00, FFEAE RSO T e 48
SGBLI

® LR SRR SR

bandmath £iL=X: (bl 1t -1)+ (bl gt 1)

® ERHH:

bandmath FiAR: (bl 1t -1)*0+ (bl gt 1)*0+ (bl ge -1 and bl le 1)*bl

B1: NDVI

3.6 18 IS A /E

1% T 32 Hi->File->0pen image File, F17F.\ 11178 7572218\ classimage.img, XA 5
NDVI 4 A 2 () e . B A 5 28 5 Y.
Mb: 1
A H: 2
WM 3
KA 4
HAh: 5

K 9. iR sRE
PATTFI X F A 4 78 55 2880550 NDVI ZE R 5 AN SO, T wquw
XA FE

(1) 7£ display H @~ ETivH 515 2/ NDVI 45 ;

(2) B E3EH->Basic Tool->Masking—>Build Mask, 7F Select In.pﬁt Display Hik
$ENDVI B SCPERTER Display & H, Xk %?}EAQKJJ&EXIT%E’JRTﬁ/JWEﬁ
HEIE R R 7N
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(3) 7F Mask Definition TH#RT, Bty Options—>Import Data Range, i#EFE+HWE
rRE. FERCOR. RAMEH RN L
(4) EEEfm AR, S8 BRSO AR
ANK M Mask Definition [HIBR, 734 A Fifth 3t 78 o5 2870 (A5 o B AE il HAth DY 2R3
At
E: HTAG PR B S RAEES NV FME R E BT P75, e LA
bandmath I 77 VEA BGEIE SO, dnARHBHE I SO ZRIE/&: bl eq Lo

9 2 Mask Definition
b — —

f:{! Input for Data Range Mask !g_—_l'\
i & - 4 Selected Srgut
Seleated ALLEIMates for Mask Bund: Bund 1 clussimage ing
Lect Bew Ligut

K 10: AR S5

.

5 #1 Scroll (0.05728) i= [ [y W

B 11 MRt s RS

3.73REURE

X Bt A2 K A% NDVImax A NDVImin, A b — B 3REURH B S5 7308 NDVIE B8 SC
PEEAT G, AR BT FEE A SR BRSO (3 2 7 5 2178 o I8 Py e KT
/INNDVIAE. T I BARR A 51 A R AN T

(1) 1 FEH i $F Basic Tools->Statistics->Compute Statistics, 1 12 fr~, 0 Hlik £

ndvi SCEFE NG VSO, BAACHRIE SO AE

(2) SRR, Ak E T EIED.
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(3) HINFITLR,

3 Compute Statistics Input Fil

==

Select Input File:

Wawvelength : Hone
Tpper Left Cormer:

File Information:

File: F:\O1EWVIDemohZ2009]KEriE iR 2 \4F
Dims: 5963 x 5935 = 1 [B3Q]
Size: [Floating Foint] 142,825, TT6 bytes.
File Type : EHVI Standard
Sensor Type: Unlmown
Byte Order @ Host (Intel)
Projection : UIM, Zone 50 North
Fixel 130 Meters
Datum T WGS-54

1845, 589
Desecription: FDVI Transform Result
[Fri Jul 27 19:18:52 2012]

[Stats Subset ] Fall Seene

Select By File 11”

‘ Select Mask Band | Mask Band:3E# img

H Mask Options v”

[ ] |

K 12:

PG SRR SO

NHEANI PG AE R, B E B SRR R AN /N NDVI R . AniX L AR 7

2 XISt a2 (B 13),
BRI,
NDVImin=0.4431,

AR ARKERE, FATERES AR E O

InixX BLF AL NDVI B AR TR N E 5 A ACy MBS XA, k%

NDVImax=0.9216.
AU R B T RN L= Ry

2%~98% 9 B.1% XA, &EUXTF”B’J NDVI {E .

0. 24%020 g.0002 0.4420 .
0.356663 0,0aa0 0. 4421

0 364706 9.00m 0 &e21
0.372545% a.0001 0. 4422
0.300292 0 .0003 0 4426
0.38B23% d.0016 0 4441

0. 396078 0.0045% 0, 4486

0 4035922 9.0127 0. 4613

0 411765 0. 0219 0.4832
0.419606 0.0413 0.5246
0.427451 0. 0661 0.5907

0 3 0

0 _450980 0.1890 1.03%%

0 458624 2.2371 1.2730

0 46660Y a3 1 5541
0D_474510 1.33%% 18937

0 §U2353 4 299 2291
0.490196 0. 4564 2 7494

0 49%003% a.6196 12690

0 506882 0.5914 3:8604
0.51372€E 0. 68538 451450
0.52166% 0.727! 5. 2410
0,529412 0 7947 6.0357 L}
0. 537265 0 9657 & 9023 |
0. 545098 0.9341 7.8364 %
D 55294] 1 00 . os0?

0 S6078¢ 1.0774 9.9181

U S6B62Y 11299 11 0500

0. 576471 1.2213 12.2753

0 S8e314 L2814 13 5607

0 592157 1.319% 14.8803

Kl 13: QEEHL AR

R BRI A R T EJE 51,

D. 756863 2E9DER TI4E2 7 1337 73 0083
0 764706 245471 618633 3.0163  76:0248
3 2 8043 70 8289

24057 B1 4346

2. 4036 03 5382

2.18%47 86.0228

L 9002 ne 0110

1.8001 89,8112

1 6031 91 4142

1.4325% 31 9468

1 2442 94.0910

1.9768 35.1678

0 9134 96.0812

0.7542 96 8358

0.6403 A7 4757

0 874510 a.521 9 00%
0. BB2363 04448 38 4508
0.8%0196 0 3646 90 #150
0.B9803% 0.2835 99.0986
0 905082 a.2156 99 3142
0_91372¢ 01683 99 4726
0929412 9.1021 99 7026
0937255 00743 99,7809
0946098 00500 39 8310
0.952841 Q.40338 99.8648
0. %0764 9.0210 9 .0650
0. 968627 0.0185  99.9043
0 976471 ¢ 0233 99 9278
0984314 0.0263 99 3528
0.992157 0 0203 2991
1.000000 9:0269 100.0000

[ERF 1) 77245 B = Ath ) 78 5525 1) NDVIL RIME, G R

7 TR NDVImin (NDVIsoil) | NDVImax (NDVlveg)
R 0.4431 0.9216
Al F Hh 0.3907 0.7896
T FH 0.0756 0.4115
KA 0 0
FHoft 0.0198 0.6576

P3k: www.esrichina.com.cn
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I KA OKEANR TR, X XIS E o5 0.

3.8 B H

X — 20 AR LT A5 201 NDVI IE 7371 4 % NDVIsoil il NDViveg 030, FE A H
bandmath T H, FRIAXUWIT:

NDVIsoil: b1*0.4431+b2*0.3907+b3*0.0756+b4*0+b5*0.0198
Hor b1 AR AR S A

b2: A%V M A

b3: I Ty F M s SO 1

ba: JKAAHERE S

b5: At HuHE A5 1
NDViveg: b1*0.9216+b2*0.7896+b3*0.4115+b4*0+b5*0.6576
For b1 AR H R S 1

b2: A%V M A

b3: 3T FH L A S

bd: JKAHERE A

b5: Hoth M HE A5

G 1 scroll (00a275)] | = B % Oy #2scroll (0.04275) | = B X

W,

14: NDVisoil F1 NDVIveg %1

3. 9B B =

FIF L —2513 %) NDVIsoil 1 NDViveg ZH i N A (2), f#iH] bandmath #E1Tit
=
£i£30: (b2 ne 0.0)*(b1-b2)/(b3-b2)
BL:NDVI( 2= 7 H51H)
B2: NDVlsoil ZH (1
B3: NDViveg 44

Phk: www.esrichina.com.cn  $RSZEEMUL: support.esrichina.com.cn  Hiif: 010-57632288 FiAR T Hr#k
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[ 1 scroll (0.05719) o S |

Bl 15 A 55 R AL R 4G

BV R, SRIA SR E, BMEE0,124h, X H (A7 NOVI BfE
FEZ AMOASER G e A ) (A NDVI FE BT . REETHEA L, KA N 1.7%/4L
o AT SRR X SR A 9 78 55 FE I {E 9-NaN,  BRJEAE, oA BEA 0 3 A

F—M R AT UM T 0 FMERRK 0, KT 1 FME R 1, A bandmath T HRIHT,
FiLHN:

0.0>b1<1.0, bl: HHWEHE

-NaN 7 AR FERSEEAT AL R, BIFE build mask H A -NaN A i .

3.10 TEHE 5 B RIEM R

® IRiE

M AR B o P S8 IE T v T 2Rl B AN B 4 R AT IAIE, W R N —Fh I

DA 1 2 ) P2 SO AR LT SRR kTR By, T GPS 78 A 3RATFRAE s
LERFEAANR o DNARATHETH AR WA 75 B2 SN B el ME  IL AR TR %, R B A B A5 21 4L
TRABIK. & =0 Ko, SRAARRE 2RIED N 10 K IFEDRER D
MR AR, DAOMORTH R A f5 R . Oy 1 ORIERAE R REWE IETRE A, BFAh—fk
ML 3X3 AMEITCR/NIIFETT, B 90m X 90m, IFTERETT s 2 kit . BN A
THE R BSMEAE BT B 5, BURETT Pl )UITAE 3 x3 AR TR A o BV X B
X I 38 SR Al BB EAT BRI

o Nk

(1) £ Display ‘. ~tE % 78 75 .

(2) ¥ Tools->Color Mapping->Density Slice, .17 Clear Range #4411k ERIA X 1]
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